Taulukkolaskentaa.Jos laskentataulukosta pitäisi laskea tietyn sarakkeelta...

Taulukkolaskentaa.Jos laskentataulukosta pitäisi laskea tietyn sarakkeelta...

Taulukkolaskentaa.
Jos laskentataulukosta pitäisi laskea tietyn sarakkeelta, kuinka monella rivillä mainitaan vaikkapa sana "iron maiden", millainen kaava pitäisi tehdä...
nim. Open Office

Vastaus

Microsoftin Excelin 2003 suomenkielisessä versiossa laskenta onnistuu, kun laittaa haluamaansa laskentataulukon soluun kaava

=LASKE.JOS(x:y;"z")

,jossa x on sarakkeen ensimmäinen solu (esim. A1) ja y on sarakkeen viimeinen solu (esim. A100) ja sitaattien sisään kohtaan z tulee sana tai lause, jonka esiintymien määrä halutaan laskea.

Jos siis haluat ohjelman laskevan vaikkapa A-sarakkeesta soluissa A1-A100 esiintyvien "iron maiden" -sanojen määrän kaavan muoto on =LASKE.JOS(A1:A100;"iron maiden")

Englanninkielisessä versiossa "LASKE.JOS"-komento on "COUNTIF".

Lähde:
http://office.microsoft.com/en-us/excel/HP052090291033.aspx

OpenOfficen taulukkolaskentaohjelman englanninkielisessä versiossa näyttää olevan vastaava "COUNTIF"-funktio. OpenOfficen internet-sivuilta löytyy Daniel R. Millerin "Manual of Calc Functions" pdf-muodossa, jonka sivulta 76 on ohjeistusta funktion käytöstä OpenOffice.org Calc -ohjelmalla:
http://sc.openoffice.org/files/documents/11/2855/file_2855.dat/Manual%20...

OpenOfficen suomenkielisiltä sivuilta en onnistunut löytämään tietoa, mikä on suomenkielisen version funktio.

Kommentit (0)

Vastauksesi